Problem

During the installation of various components the Windows Installer Coordinator will appear to hang, saying "Please wait while the application is preparing for the first use".  You may also get an error saying "Install server not responding".

Windows installer coordinator

https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009877309/original/mceclip0.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T171304Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=df0da44ea00ba28fe905b3fd3bd6f0d51b6641e093411063ca2fb0fb14321205

 

Resolution

  1. Open the Local Group Policy Editor (gpedit.msc)
  2. In the left pane, go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Application Compatibility
  3. In the right pane, double-click Turn off Windows RDS Compatibility

  4. Select Enabled and click OK
    https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/69009877309/original/mceclip0.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAS6FNSMY2XLZULJPI%2F20210926%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210926T171304Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=df0da44ea00ba28fe905b3fd3bd6f0d51b6641e093411063ca2fb0fb14321205
  5. Run the desired installer again.
  6. Optional: Repeat steps 1-4, and return the "RDS" option to its previous setting. (E.g. set the option back to Enabled).
 

 

Cause

This issue is caused by incompatibility between Embedded MSI and Windows Installer Coordinator. Suggestion is to enable "Turn off Windows Installer RDS Compatibility" for the duration of the installation. More information about the issue and resolution can be found here (http://support.microsoft.com/kb/2655192).